Try TT Now

All Gateways

Enabling the Enhanced Order/Fill Delivery

Upgrading the Environment

Before migrating your trading environment to support the Enhanced Order/Fill Delivery, identify all applications in the environment that need to be upgraded to support the new messaging system. For a complete list of TT products that support this enhancement, review Supported Applications.

Note

TT provides backwards compatibility allowing the user to upgrade each component in the trading environment without negatively impacting existing products.

However, to obtain the full performance gains from this enhancement, all related products in your trading environment must be on a version that supports the new functionality.

As you add applications that support the Enhanced Order/Fill Delivery, performance increases for the entire environment.

In this diagram, the older X_TRADER benefits from the reduced traffic provided by the upgraded applications.

Supported Applications

The following is a list of the minimum client application versions that support the Enhanced Order/Fill Delivery.

Supported Client Applications

Client Applications

Availability

X_TRADER® 7.9.4

Released

X_TRADER API 7.7.2

Released

FIX Adapter 7.7.2

Released

X_RISK® 7.5.0

Released

AutoSpreader SE 7.1.3

Released

Synthetic SE 7.2.2

Released

Historical Fill Server 7.5.0

Released

Note

To achieve optimal performance and reliability, TT recommends that you install the most current production releases.

The Enhanced Order/Fill Delivery functionality is part of all TT Gateways Version 7.15 and higher.