Try TT Now

All Gateways

Price Server: FAQs

PFX Reliability

If I miss a snapshot and the product is thinly traded, am I going to see stale data until the product trades again?

The PFX algorithm will send out periodic snapshots even if the product hasn’t been traded during each period. The time between the snapshots is optimized by TT for each TT Gateway. This setting, as with all other PDD parameters, should not be changed unless instructed to do so by TT support.

Levels of Depth

Can I display more than 25 levels of depth on my trading application screen?

It is not possible to get more than 25 levels of aggregate or implied depth.

How many levels of detailed depth can I receive?

Currently, TT Gateways support a maximum of 25 detailed depth entries per side. This limit will be expanded in upcoming TT Gateway and X_TRADER releases.

PFX, XTAPI, and FIX Clients

If I am running XTAPI 7.4 or earlier, can I get inside market information with XTAPI’s Guaranteed Price Delivery feature from a PFX-capable gateway running in CoreAPI mode?

Guaranteed price feed functionality for inside market data is not available from a PFX-capable gateway, even if it’s running in CoreAPI mode. The interface is still present in XTAPI 7.4 and you will be able to see inside market information. However, there is a possibility that you may miss some inside market activities.

If I am running XTAPI 7.5 or later, can I get inside market information with XTAPI’s Guaranteed Price Delivery feature from a PFX-capable gateway running in either PFX or CoreAPI mode?

No. The interface for guaranteed price delivery of Inside Market data has been removed from XTAPI 7.5 and higher.

What changes do I need to make to my XTAPI application in order to consume PFX prices?

Rebuild your application with XTAPI 7.5.0 or higher. No other changes are required.

What changes do I need to make to my FIX client application in order to consume PFX prices?

No changes to FIX client applications are required. However, the FIX Adapter you connect to must be version 7.5.0 and higher.