Try TT Now

Welcome to TT Update

Overview

  TT Update provides an easy way to keep X_TRADER, X_RISK and TT User Setup up-to-date. A one-time installation of the TT Update program provides access to all future updates of client applications. Administrators assign specific versions of client applications to the end-user. Software updates are deployed over the internet from cloud-based servers directly to the end user’s machine.   The login screen informs the user when a different version of the client software (e.g., upgrade, downgrade, beta, etc.) is available. Depending on the Version Rules in TT User Setup, traders can decide to immediately take the update, or skip the update and continue their normal login process.   This approach offers the following major advantages over the current installation process:  
    • Simpler upgrade process: TT Update delivers software updates directly to the workstation and requires a single click to begin the upgrade process.
 
    • Reduced security permissions: TT Update applications require administrative permissions only during the initial installation of the TT Update software. Once TT Update is installed, standard users can upgrade the application.
 
    • Secure downloads: Downloaded files are digitally signed with TT’s corporate software publishing certificate.
 
    • Administrator control: The version rules are configured in TT User Setup, and the user’s current version is checked against the desired version as part of the login process. Actions can be set to either warn the user of new versions or reject their login if they do not meet the version requirements.
 

Supported Versions and Operating Systems

  TT Update will be available for installing and upgrading the following products and versions:  
    • TT User Setup 7.17.40 and higher
 
    • X_TRADER® 7.17.40 and higher
 
    • X_RISK® 7.17.40 and higherNote: In addition to the main software package, TT Update will also update versions of TT supporting software such as Guardian and TTM.  
  Also, TT Update supports client applications that run on the following operating systems:  
    • Windows 8
 
    • Windows 7
 
    • Windows XP SP3: Note: TT Update will not install on older service pack release (i.e., SP1 or SP2) of Windows XP.