Try TT Now

Before You Begin

Chapter Overview

This chapter describes how to initially install and configure TT User Setup Clients and Servers. For upgrade instructions, refer to the topics listed under Upgrading TT User Setup.

Client Prerequisites

The client machine must meet the hardware and software requirements listed in the latest TT Trading Systems Hardware and Software Requirements document.

Server Prerequisites

The TT User Setup Server requires the following:

  • The server machines must meet the hardware and software requirements listed in the latest TT Trading Systems Hardware and Software Requirements document.
  • Windows Administrative permissions on the machine on which you're installing TT User Setup. .NET Framework 4.0.
  • TT User Setup Server license(s). You can acquire TT User Setup licenses by requesting a free LOGIN Server license for each TT User Setup server in your network. You will need to provide the IP address of each TT User Setup server. Once the new license is applied, it will appear in Guardian under the TT Global exchange as a LOGIN Server.
  • If you are currently using AutoCredit, ensure you have version 2.2.0 installed. Other versions are not compatible with TT User Setup 7.4.
  • If there are TT Gateways already installed in this network, obtain a copy of the TT Gateway’s aconfig.xml file. You will need this file when installing the TT User Setup Server. Otherwise, TT User Setup will create a new aconfig.xml file. For information on how the TT system replicates aconfig.xml across your TT system, refer to the TT Gateway Architecture System Administration Manual Version 7.X.

Guardian 7.9.2 and TT API

This release of TT User Setup contains Guardian/GuardServer 7.9.2. If you are currently using or planning to use TT API, please discuss the licensing implications with your TAM prior to installing TT User Setup. �