Try TT Now

CME Gateway

Upgrading

Preparing to Upgrade

Warning

The CME Gateway Version 7.13.0 and higher will abort an installation or upgrade if your machine is running Windows 2000. Before installing or upgrading to Version 7.13.0 and higher, you must ensure that your machine is on a version of the Windows platform supported by TT. Please refer to the https://customernet.tradingtechnologies.com/Extranet/Downloads/Documentation/Hardware_Software_Requirements_V7X.pdfTT Trading Systems - Hardware and Software Requirements Version 7.X document for details.

You can upgrade to a higher version of the CME Gateway by running the installation package on the same machine.

Stopping Services

Prior to running the installation package, the user must manually stop all TT Gateway services.

Running the installation package automatically stops the following TT-related processes: TT Chron, SNMP, TT Guardian, TT Guardian Server, TT Guardian Control, TTMRD, and TTMD.

Note

Failure to stop all services causes the installer to log the following message in the installation logfile:

Error: Service <ServiceName> failed to stop. Please shutdown all TT applications and then re-launch this install.

If this message appears, you must manually stop the service(s) and restart the CME Gateway setup.

Backing Up Audit Files

If upgrading intraday, you must backup and rename the Audit File which was created that day. Audit Files are version specific. Due to potential changes, TT strongly recommends that you backup and rename the day’s Audit File. This allows the upgraded TT Gateway to create a new version of the day’s Audit File and avoid any potential errors.

Warning

Audit Files that contain content from multiple TT Gateway versions cannot be converted with the Audit Convert tool.

Failure to begin a new file when upgrading the TT Gateway results in an ‘Unknown record type’ error message and potentially lost data.

TT strongly recommends that you backup and rename the day’s Audit File if upgrading intraday.

For information about updating your configuration files when upgrading, refer to Master Files .

Product Dependencies

The following is a list of the minimum client application versions that support the PFX wire format. You need to upgrade to these versions in order to support PFX in your trading environment.

Note

To achieve optimal performance and reliability, TT recommends that you install the most current production release available for each of the products listed in this section.

PFX-Capable Client Applications
Client ApplicationsAvailability
X_TRADER® 7.7.3Released
X_TRADER API 7.5.0Released
FIX Adapter 7.5.0Released
Price Proxy 7.1.0Released
X_STUDY™ 7.3Released
X_RISK® 7.4.1Released
AutoSpreader® 7.0.0Released
FMDS 7.4.3Released

CME Gateways require these versions, or higher, to also support the following:

  • FIX Adapter 7.2.3 or higher: Contains fixes for issues related to the sharing of market IDs and additional contract issues.
  • User-Defined Strategies: X_TRADER® 7.5.2 and higher is needed to display user-defined strategies that enter the market. This allows users to process and trade user-defined strategies that are working in the market. X_TRADER® 7.6 or higher is needed to create a UDS.
  • For client applications that support the CME Group’s Mandatory iLink Tag requirements, refer to Upgrade Tasks to Support Mandatory iLink Tags.

Please contact your TAM to determine configuration changes and requirements specific to your trading environment.

Master Files

To help accurately update your configuration files during upgrades, CME Gateways install with the following template “Master” configuration files located in the <root drive>:ttExchange-Flavor folder:

  • hostinfo.cfg_master
  • ttchron.ini_master
  • ttclean.ini_master
  • mdp.cfg_master
  • fast.cfg_master
    Note

    You should not manually update the fast.cfg file. During upgrades, CME Gateways overwrite the existing fast.cfg file with the proper settings.

    The fast.cfg_master file serves solely as an additional reference for troubleshooting.

  • ttclean.ini

These files contain updated settings and parameters for the upgraded version of the TT Gateway. When upgrading, the CME Gateway retains your previous configuration settings. After installing, you can update your configuration files by copying the relevant changes from the Master files to your existing configuration files. This is illustrated in the following procedure:

To update your existing configuration files using the Master files as reference:

  1. Open both the existing configuration file and the related Master File.
  2. Copy changes from the Master File and paste into the relevant sections of the original configuration file.
  3. Save your changes and close both files.
  4. You can continue to edit your configuration files as described in the configuration sections.